Repair AdviceCars

Truck Heater Blower Won't Work on High Speed

Category Repair Advice

The blower on my '91 Explorer was only working a little bit. It had all the signs of the resistor going bad, so I replaced the resistor. Now the blower works at the lower speeds, but not at the high speed. What might the problems be?

Ad

By William

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

January 14, 20140 found this helpful

I'm pretty sure it's the wiring harness. I had a Chevrolet Colorado with the exact issue and it was the wiring harness. If possible you could take to a garage that specializes in electrical issues and have the work done much, much cheaper than dealer. Hope this helps.

Reply Was this helpful? Yes

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Related Content
Categories
Consumer Advice Cars Repair AdviceJanuary 12, 2014
Guides
More
👔
Father's Day Ideas!
👒
Mother's Day Ideas!
🌻
Gardening
🐛
Pest Control
Facebook
Pinterest
YouTube
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Better LivingBudget & FinanceBusiness and LegalComputersConsumer AdviceCraftsEducationEntertainmentFood and RecipesHealth & BeautyHolidays and PartiesHome and GardenMake Your OwnOrganizingParentingPetsPhotosTravel and RecreationWeddings
Desktop Page | View Mobile

Disclaimer | Privacy Policy | Contact Us

© 1997-2018 by Cumuli, Inc. All Rights Reserved.

Published by ThriftyFun.

Generated 2018/04/17 19:14:19 in 796 msecs. ⛅️️ ⚡️
Loading Something Awesome!