Electric Blanket Control Displaying Code E

We have a Biddeford blanket with 2 controls. One control has an E showing with no heat. Can you help me out?

By Bill B.

Ad

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

March 19, 201511 found this helpful

Below is a customer response I found on a customer review site:
"E message fixed
We had the same problem. Our controller display just said "E". for us it meant that the controller cord was disconnected from the mattress pad at the foot of the bed. Try that."

The site also had many negative reviews about Biddeford customer service:

www.reviewstalk.com/.../biddeford-blankets-l15123.html)

Reply Was this helpful? 11
Anonymous
May 20, 20162 found this helpful

We appreciate the assistance with this - ours displayed "E" as well and it was the connection on the mattress being not plugged in all of the way.

Reply Was this helpful? 2
February 10, 20172 found this helpful

This ended up being the problem with mine, thank you so much! The cold was killing me

Reply Was this helpful? 2
Anonymous
October 27, 20171 found this helpful

That worked for me too! Thank you so much!

Reply Was this helpful? 1
October 29, 20171 found this helpful

That helped. Pushing in the cords replaced the E with numbers. Thanks

Reply Was this helpful? 1
Anonymous
November 16, 20171 found this helpful

I made sure it was plugged in and still shows an E

Reply Was this helpful? 1
December 22, 20171 found this helpful

its plugged in and still show E

Reply Was this helpful? 1
January 19, 20180 found this helpful

So does mine still show the E. I can turn on a number and before five minutes its back to E. again.

Reply Was this helpful? Yes
January 22, 20180 found this helpful

Worked for mine! Said E, searched why came across this thread and pushed the plug in where it came loose. Happy camper now!

Reply Was this helpful? Yes
January 28, 20180 found this helpful

Thanks so much for the answer to this problem. Mine has been showing a Code E for a couple of nights with no heat. I decided to Google the problem and found this comment.

Ad

I checked my connection to the plug and that was the problem. I plugged it back in and problem solved. Thanks a million!!! It has been very cold without it!!!

Reply Was this helpful? Yes
Anonymous
February 6, 20180 found this helpful

The awful E code. I untangled the blapert

Reply Was this helpful? Yes
February 10, 20180 found this helpful

Mine still wont work either!!!

Reply Was this helpful? Yes
Anonymous
March 9, 20180 found this helpful

I turned it off then on and it worked

Reply Was this helpful? Yes
Anonymous
March 15, 20180 found this helpful

I took your suggestion and it cleared the "E" Code on my Biddleford Heated Blanket. It was not obvious that it was disconnected so I would not noticed it without closely examining it. Thank you, thank you, thank you!

Reply Was this helpful? Yes
March 21, 20180 found this helpful

I can not get the "E" code go away. Tried plugging and switching sides, with no results. Please help. I live in New England.

Reply Was this helpful? Yes
Anonymous
April 15, 20180 found this helpful

I've tried everything you said mine is still not working unplugged it plugged it left it on for a couple hours I don't know what else to do I'm very frustrated one side works one side doesn't

Reply Was this helpful? Yes
April 21, 20180 found this helpful

What do you mean by blazers?

Reply Was this helpful? Yes
Anonymous
October 15, 20180 found this helpful

I turned the plug over and put it back in and no E!

Reply Was this helpful? Yes
October 17, 20180 found this helpful

If it says E make sure the cord is all the way in and its turned the right way

Reply Was this helpful? Yes
Anonymous
October 19, 20180 found this helpful

I turned it off and then turned it back on and now it works. Thank u!

Reply Was this helpful? Yes
October 25, 20180 found this helpful

SAME and I dont get enough iron as it is so I ALWAYS freeze and I dont know what to do!

Reply Was this helpful? Yes
November 22, 20180 found this helpful

I have a Beautyrest electric blanket and when I turn it on it only shows sn "E". I looked at the comments and some of them said to be sure the blanket connection was hooked up OK.

Ad

Mine was all right so it is not the problem . Thank you for any help you can give me !!!

Reply Was this helpful? Yes
November 25, 20180 found this helpful

This answer just worked for me. Thank you. Shari

Reply Was this helpful? Yes
October 10, 20160 found this helpful

I got a error code E4 non one side of electric blanket

Reply Was this helpful? Yes
November 30, 20170 found this helpful

Thank you for your comment Now my problem is solved!!! My cord was disconnected from the heated mattress pad!! ;))

Reply Was this helpful? Yes
March 20, 20180 found this helpful

Have u ever gotten an answer to your question? I have the E4 error now.

Reply Was this helpful? Yes
December 18, 20162 found this helpful

My blanket control has the E display. How do I fix it?

Reply Was this helpful? 2
January 16, 20180 found this helpful

See of the second cord is plugged into your blanket

Reply Was this helpful? Yes
Anonymous
March 10, 20180 found this helpful

How do I fix it

Reply Was this helpful? Yes
March 21, 20180 found this helpful

I still have the problem after checking plugs my over blanket still showing E. Please help. Joy

Reply Was this helpful? Yes
April 27, 20180 found this helpful

has a e don't work

Reply Was this helpful? Yes
January 7, 20171 found this helpful

we have model #BST.CONT.05.CD.TK One control shows E and other control has nothing on it.any ideas.Tom

Reply Was this helpful? 1
March 10, 20180 found this helpful

It was fixed. I unplugged and plugged it back. It was connection. Thanks!

Reply Was this helpful? Yes
October 16, 20180 found this helpful

Pushing in the connector Worked for me! Also, I have had good experiences with Biddeford customer service, they replaced my heated bed cover a few months ago under the 5 year warranty.

Reply Was this helpful? Yes
November 10, 20180 found this helpful

Thank you for helping me to get the control back to working. I plugged it in all of the way and the E disappeared. So happy as I have been freezing without it!!

Reply Was this helpful? Yes
Ad

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Related Content
In This Guide
Categories
Home and Garden Repair OtherMarch 19, 2015
Guides
More
🎄
Christmas Ideas!
🎉
New Years Ideas!
Facebook
Pinterest
YouTube
Instagram
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Better LivingBudget & FinanceBusiness and LegalComputersConsumer AdviceCraftsEducationEntertainmentFood and RecipesHealth & BeautyHolidays and PartiesHome and GardenMake Your OwnOrganizingParentingPetsPhotosTravel and RecreationWeddings
Published by ThriftyFun.

Desktop Page | View Mobile

Disclaimer | Privacy Policy | Contact Us

© 1997-2018 by Cumuli, Inc. All Rights Reserved.

Generated 2018/12/06 10:36:24 in 2 secs. ⛅️️
Loading Something Awesome!