social

Riding Mower Blows the Fuse When Engaging Blades?

My riding mower blows the 20 amp fuse when I try to engage the blades. I've replaced the seat switch, blade engagement switch, and electric clutch.

Advertisement

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

April 14, 20190 found this helpful

It may be the wiring going to the electric clutch.

Reply Was this helpful? Yes
April 17, 20190 found this helpful

Sure sounds like a wiring problem.
Did you happen to check the wiring - from mower to clutch - when you installed a new clutch to blades (beginning to end)?

You might try starting after dark to see if you see a flash somewhere (might need a second person to help).
Was this the reason you replaced all those parts?

I think you should go back to the store where parts were purchased and ask someone in their maintenance department to help you.
Otherwise I would suggest you visit a farm supply store and see if someone there can help you.

Reply Was this helpful? Yes
Anonymous
April 17, 20190 found this helpful

Thanis, I ran new wire to the clutch and Im up and running.

Reply Was this helpful? Yes
Advertisement

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Advertisement

In This Page
Categories
Home and Garden Repair Machines Lawn MowersApril 14, 2019
Pages
More
💘
Valentine's Ideas!
🍀
St. Patrick's Ideas!
Facebook
Pinterest
YouTube
Instagram
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Better LivingBudget & FinanceBusiness and LegalComputersConsumer AdviceCoronavirusCraftsEducationEntertainmentFood and RecipesHealth & BeautyHolidays and PartiesHome and GardenMake Your OwnOrganizingParentingPetsPhotosTravel and RecreationWeddings
Published by ThriftyFun.
Desktop Page | View Mobile
Disclaimer | Privacy Policy | Contact Us
Generated 2021-02-05 03:13:28 in 2 secs. ⛅️️
© 1997-2021 by Cumuli, Inc. All Rights Reserved.
https://www.thriftyfun.com/Riding-Mower-Blows-the-Fuse-When-Engaging-Blades.html