Next >︎
To Top

Car Idling Rough and Slow to Accelerate

I have a 2003 Mitsubishi Outlander AWD. All has been going well lately. Yesterday the "service" light came on. There are no issues when driving. This morning when I turned the car on, it was a little rough on the idle. Then when I put the car into drive, there was nothing at the acceleration. I mean when I put the gas pedal down to the floor, I slowly started to accelerate. The car sounds a little weird as in sputtering, but not what I think is running on less than 4 cylinders. Any ideas?

Ad

We are giving away $200 in Amazon gift cards (US only) for people who answer recent questions on ThriftyFun this month! Click here to find out more...

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

February 6, 20170 found this helpful
Best Answer

From bimmerforums.com:

It could be many things, including camshaft sensors, Oxygen sensors, vanos seals,fuel issues, adjuster unit, ICV, coils, sparkplugs and vacuum leaks.

Reply Was this helpful? Yes
February 8, 20170 found this helpful

Check for fouled plugs or cracks in the plug wires . Could be your fuel filter also

Reply Was this helpful? Yes
February 21, 20170 found this helpful

It could be many many things. The easiest would be if your gas cap is on too tight causing a vacuum. Check that first. Did you recently get fuel? Could it have water in it?

Reply Was this helpful? Yes
Ad

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Related Content
In This Guide
Next >︎
Categories
Home and Garden Repair CarsFebruary 6, 2017
Guides
More
🍂
Thanksgiving Ideas!
🎃
Halloween Ideas!
Facebook
Pinterest
YouTube
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Desktop Page | View Mobile

Disclaimer | Privacy Policy | Contact Us

© 1997-2017 by Cumuli, Inc. All Rights Reserved.

Published by .

Generated 2017/10/19 12:07:40 in 2 secs. ⛅️️
Loading Something Awesome!