H2O Steam Mop Makes Noise But No Steam

Can anyone help me please? My wife's steam mop H2O x5 stopped putting out steam. All it does is go hum hum hum hum kind of pulsing like. The element gets hot, but it doesn't put out steam. I think maybe the pump is bad.

Ad

By Nicholas Wayne W.

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

June 5, 20130 found this helpful

I have one. It gets plugged with the minerals in the water. I clean the holes in the bottom with vinegar. I put about 1/4 inch of vinegar into a pan big enough to set the mop in, and let it soak overnight. I only have to do this once every couple of months. I've had my steam mop for about 7 years now.

Reply Was this helpful? Yes

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Related Content
In This Guide
Categories
Home and Garden Cleaning Cleaning ToolsJune 3, 2013
Guides
More
🐛
Pest Control
🌻
Gardening
🐰
Easter Ideas!
👒
Mother's Day Ideas!
Facebook
Pinterest
YouTube
Instagram
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Better LivingBudget & FinanceBusiness and LegalComputersConsumer AdviceCraftsEducationEntertainmentFood and RecipesHealth & BeautyHolidays and PartiesHome and GardenMake Your OwnOrganizingParentingPetsPhotosTravel and RecreationWeddings
Published by ThriftyFun.

Desktop Page | View Mobile

Disclaimer | Privacy Policy | Contact Us

© 1997-2019 by Cumuli, Inc. All Rights Reserved.

Generated 2019/04/02 13:41:31 in 1 secs. ⛅️️
Loading Something Awesome!