2007 Ford Edge Windshield Washer Pump Not Working?

I have no power to the windshield washer pigtail at the pump on my 2007 Ford Edge. The pump works fine when 12 volts are applied directly to it. I can't see where this has a fuse or relay to check according to the owner's manual. Any ideas?

Advertisement

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

October 6, 20180 found this helpful

There could be a clog in the line

Reply Was this helpful? Yes
October 10, 20180 found this helpful

I am of the mind not to mess with car things any more and take it a local mechanic who is honest and reasonable...there are still some out there. The newer cars just aren't like the old ones where even a not so handy person can fix them fairly easily...now everything is hard to reach, hidden behind stuff etc.

I learned the hard way, sometimes going to the shop is the cheapest way to go...vs. me messing with something and making it worse.

Just my two cents worth from someone who misses the old cars!!

Reply Was this helpful? Yes
Advertisement

Add your voice! Click below to answer. ThriftyFun is powered by your wisdom!

Advertisement

In This Page
Categories
Home and Garden Repair CarsOctober 6, 2018
Pages
More
🌻
Gardening
📓
Back to School Ideas!
😎
Summer Ideas!
🐛
Pest Control
😷
Coronavirus Tips
Facebook
Pinterest
YouTube
Instagram
Contests!
Newsletters
Ask a Question
Share a Post
Categories
Better LivingBudget & FinanceBusiness and LegalComputersConsumer AdviceCoronavirusCraftsEducationEntertainmentFood and RecipesHealth & BeautyHolidays and PartiesHome and GardenMake Your OwnOrganizingParentingPetsPhotosTravel and RecreationWeddings
Published by ThriftyFun.
Desktop Page | View Mobile
Disclaimer | Privacy Policy | Contact Us
Generated 2020-07-18 13:21:21 in 2 secs. ⛅️️
© 1997-2020 by Cumuli, Inc. All Rights Reserved.
https://www.thriftyfun.com/2007-Ford-Edge-Windshield-Washer-Pump-Not-Working.html